Magic Launcher Mod for Minecraft 1.7/1.6

October 9, 2013
one response
35.1K views

Categories: Minecraft Mods, Popular Mods

The Magic Launcher for Minecraft is a Minecraft Launcher with the added ability to launch mods without changing or patching the minecraft.jar file. This means that you can easily add new mods, without having to think about moving .jar files and changing other files.

It is compatible with Forge, so both should work at the same time without any issues.

It is very easy to use and “install”, simply download the launcher and launch it, that is all it takes.

Magic Launcher for Minecraft


Here are the current features of the Magic Launcher:

  • For Minecraft:
    • selectable minecraft.jar
    • selectable environment
    • automatic version detection
    • configurable window size, also maximized
    • selectable minecraft folder
    • selectable java executable
    • java memory limit
    • java custom parameters
    • show error log
    • multiple user profiles
    • remember password
    • configuration profiles
  • For Mods:
    • load mods dynamically without changing minecraft.jar
    • META-INF does not have to be deleted
    • automatic mod compatibility checking
    • external mods detection and compatibility checking
    • shortcut to external mods folder
    • configurable external mods
    • automatic mod requirements checking (ModLoader, ModLoaderMP, Forge, GuiAPI)
  • Designs:
    • Minecraft style
  • News Displayed:
    • Minecraft
    • Reddit
    • Twitter
    • Blogspot

Magic Launcher for Minecraft

How to install Magic Launcher for Minecraft:

  • Simply download, extract and run the file/launcher. If you have any issues with Minecraft 1.6.2 or higher, look below.

Currently, some issues may be present for Minecraft 1.6.2 and above, and you have to change a few things to run it in 1.6.2 and above:

To run Minecraft 1.6.2+, go to Setup -> Environment and from here select 1.6.2. Should the Environment 1.6.2 be unavailable, then use the vanilla launcher to download and start Minecraft 1.6.2, and then Environment 1.6.2 should appear on the list.

To run Minecraft 1.6.2+ with Forge, go to Setup -> Environment and from here 1.6.2_Forge_XYZ. Should the Environment 1.6.2_Forge not be available, then use the vanilla launcher to download and start Minecraft 1.6.2, and then use the Forge installer to install Forge. Environment 1.6.2_Forge_XYZ should now appear on the list.

Download File